6.1med
CVE-2018-9244
GitLab Community and Enterprise Editions version 9.2 up to 10.4 are vulnerable to XSS because a lack of input validation in the milestones…
Published 8 y ago · modified 4 mo ago · JSON
CVSS
6.1
v3.0 · NVD
CISA KEV
No
not known exploited
EPSS
0.8%
percentile 56%
Public exploits
0
none known
Summary
GitLab Community and Enterprise Editions version 9.2 up to 10.4 are vulnerable to XSS because a lack of input validation in the milestones component leads to cross site scripting (specifically, data-milestone-id in the milestone dropdown feature). This is fixed in 10.6.3, 10.5.7, and 10.4.7.
Exploit prediction (EPSS)
0.79% probability of exploitation in the next 30 days, higher than 56% of all scored CVEs.
CVSS scores
| Assigned by | Version | Score | Vector |
|---|---|---|---|
| NVD | 3.0 | 6.1 | CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N |
| NVD | 2.0 | 4.3 | AV:N/AC:M/Au:N/C:N/I:P/A:N |
Classification
- Weakness
- CWE-79 Improper Neutralization of Input During Web Page Generation
- Technology feeds
- GitLab (RSS, critical only)
References
- gitlab.com /gitlab-org/gitlab-ce/issues/41838 · x_refsource_CONFIRM, x_transferred
- about.gitlab.com /2018/04/04/security-release-gitlab-10-dot-6-dot-3-released/ · x_refsource_MISC, x_transferred
Sources
- CVE List: CVE-2018-9244
- NVD: CVE-2018-9244
vulnwire keeps one entry per vulnerability: the CVE id wins, then GHSA; records that alias each other are merged. Machine-readable: JSON.