8.8high

CVE-2017-7235

cfscrape Improper Input Validation vulnerability

Also known as GHSA-5mc5-5j6c-qmf9, PYSEC-2017-7

Published 9 y ago · modified 4 mo ago · JSON

CVSS
8.8
v3.0 · NVD
CISA KEV
No
not known exploited
EPSS
1.5%
percentile 75%
Public exploits
0
none known

Summary

An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.

Exploit prediction (EPSS)

1.55% probability of exploitation in the next 30 days, higher than 75% of all scored CVEs.

CVSS scores

Assigned byVersionScoreVector
NVD3.08.8CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
NVD2.06.8AV:N/AC:M/Au:N/C:P/I:P/A:P
GitHub3.08.8CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected packages

EcosystemPackageAffectedFixed in
pypicfscrape
>=1.6.6, <1.8.0
1.8.0

Classification

Weakness
  • CWE-20 Improper Input Validation

References

  • github.com /Anorov/cloudflare-scrape/releases/tag/1.8.0 · x_refsource_CONFIRM, x_transferred
  • github.com /Anorov/cloudflare-scrape/issues/97 · x_refsource_CONFIRM, x_transferred
  • securityfocus.com /bid/97191 · vdb-entry, x_refsource_BID, x_transferred
  • nvd.nist.gov /vuln/detail/CVE-2017-7235 · advisory
  • github.com /Anorov/cloudflare-scrape · package
  • github.com /advisories/GHSA-5mc5-5j6c-qmf9 · advisory
  • github.com /pypa/advisory-database/tree/main/vulns/cfscrape/PYSEC-2017-7.yaml · web
  • web.archive.org /web/20170701161512/http://www.securityfocus.com/bid/97191 · web

Sources

vulnwire keeps one entry per vulnerability: the CVE id wins, then GHSA; records that alias each other are merged. Machine-readable: JSON.