CVE-2017-20155
Sterc Google Analytics Dashboard for MODX Internal Search widget.analytics.tpl cross site scripting
Published 3 y ago · modified 4 mo ago · JSON
Summary
A vulnerability was found in Sterc Google Analytics Dashboard for MODX up to 1.0.5. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file core/components/analyticsdashboardwidget/elements/tpl/widget.analytics.tpl of the component Internal Search. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.0.6 is able to address this issue. The identifier of the patch is 855d9560d3782c105568eedf9b22a769fbf29cc0. It is recommended to upgrade the affected component. The identifier VDB-217069 was assigned to this vulnerability.
Exploit prediction (EPSS)
0.65% probability of exploitation in the next 30 days, higher than 51% of all scored CVEs.
CVSS scores
| Assigned by | Version | Score | Vector |
|---|---|---|---|
| CNA | 3.1 | 3.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N |
| CNA | 3.0 | 3.5 | CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N |
| CNA | 2.0 | 4.0 | AV:N/AC:L/Au:S/C:N/I:P/A:N |
| CNA | 3.1 | 3.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N |
| NVD | 3.1 | 6.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N |
| CNA | 2.0 | 4.0 | AV:N/AC:L/Au:S/C:N/I:P/A:N |
Affected products
- Sterc Google Analytics Dashboard for MODX
Classification
- Weakness
- CWE-79 Improper Neutralization of Input During Web Page Generation
References
- vuldb.com /?id.217069 · vdb-entry, x_transferred
- vuldb.com /?ctiid.217069 · signature, permissions-required, x_transferred
- github.com /Sterc/Analytics-dashboard-widget/issues/11 · issue-tracking, x_transferred
- github.com /Sterc/Analytics-dashboard-widget/pull/12 · issue-tracking, x_transferred
- github.com /Sterc/Analytics-dashboard-widget/commit/855d9560d3782c105568eedf9b22a769fbf29cc0 · patch, x_transferred
- github.com /Sterc/Analytics-dashboard-widget/milestone/2 · patch, x_transferred
Sources
- CVE List: CVE-2017-20155
- NVD: CVE-2017-20155
vulnwire keeps one entry per vulnerability: the CVE id wins, then GHSA; records that alias each other are merged. Machine-readable: JSON.