8.1high
CVE-2017-0902
RubyGems has Origin Validation Error vulnerability
Also known as GHSA-73w7-6w9g-gc8w
Published 9 y ago · modified 4 mo ago · JSON
CVSS
8.1
v3.0 · NVD
CISA KEV
No
not known exploited
EPSS
4.8%
percentile 92%
Public exploits
0
none known
Summary
RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.
Exploit prediction (EPSS)
4.75% probability of exploitation in the next 30 days, higher than 92% of all scored CVEs.
CVSS scores
| Assigned by | Version | Score | Vector |
|---|---|---|---|
| NVD | 3.0 | 8.1 | CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H |
| NVD | 2.0 | 6.8 | AV:N/AC:M/Au:N/C:P/I:P/A:P |
| GitHub | 3.0 | 8.1 | CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H |
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rubygems | rubygems-update | <2.6.13 | 2.6.13 |
Affected products
- HackerOne RubyGems
Classification
References
- usn.ubuntu.com /3685-1/ · vendor-advisory, x_refsource_UBUNTU, x_transferred
- usn.ubuntu.com /3553-1/ · vendor-advisory, x_refsource_UBUNTU, x_transferred
- access.redhat.com /errata/RHSA-2018:0585 · vendor-advisory, x_refsource_REDHAT, x_transferred
- debian.org /security/2017/dsa-3966 · vendor-advisory, x_refsource_DEBIAN, x_transferred
- access.redhat.com /errata/RHSA-2018:0378 · vendor-advisory, x_refsource_REDHAT, x_transferred
- securitytracker.com /id/1039249 · vdb-entry, x_refsource_SECTRACK, x_transferred
- access.redhat.com /errata/RHSA-2017:3485 · vendor-advisory, x_refsource_REDHAT, x_transferred
- lists.debian.org /debian-lts-announce/2018/07/msg00012.html · mailing-list, x_refsource_MLIST, x_transferred
- access.redhat.com /errata/RHSA-2018:0583 · vendor-advisory, x_refsource_REDHAT, x_transferred
- security.gentoo.org /glsa/201710-01 · vendor-advisory, x_refsource_GENTOO, x_transferred
- securityfocus.com /bid/100586 · vdb-entry, x_refsource_BID, x_transferred
- github.com /rubygems/rubygems/commit/8d91516fb7037ecfb27622f605dc40245e0f8d32 · x_refsource_MISC, x_transferred
- hackerone.com /reports/218088 · x_refsource_MISC, x_transferred
- blog.rubygems.org /2017/08/27/2.6.13-released.html · x_refsource_MISC, x_transferred
- nvd.nist.gov /vuln/detail/CVE-2017-0902 · advisory
- github.com /rubygems/rubygems · package
- usn.ubuntu.com /3553-1 · web
- usn.ubuntu.com /3685-1 · web
- web.archive.org /web/20170907040741/http://www.securityfocus.com/bid/100586 · web
- web.archive.org /web/20170907215801/http://www.securitytracker.com/id/1039249 · web
Sources
- CVE List: CVE-2017-0902
- GitHub Advisory: GHSA-73w7-6w9g-gc8w
- NVD: CVE-2017-0902
vulnwire keeps one entry per vulnerability: the CVE id wins, then GHSA; records that alias each other are merged. Machine-readable: JSON.