7.5high
CVE-2017-0900
RubyGems Improper Input Validation vulnerability
Also known as GHSA-p7f2-rr42-m9xm
Published 9 y ago · modified 4 mo ago · JSON
CVSS
7.5
v3.0 · NVD
CISA KEV
No
not known exploited
EPSS
8.5%
percentile 95%
Public exploits
0
none known
Summary
RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications to cause a denial of service attack against RubyGems clients who have issued a `query` command.
Exploit prediction (EPSS)
8.49% probability of exploitation in the next 30 days, higher than 95% of all scored CVEs.
CVSS scores
| Assigned by | Version | Score | Vector |
|---|---|---|---|
| NVD | 3.0 | 7.5 | CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H |
| NVD | 2.0 | 5.0 | AV:N/AC:L/Au:N/C:N/I:N/A:P |
| GitHub | 3.0 | 7.5 | CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H |
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rubygems | rubygems-update | <2.6.13 | 2.6.13 |
Classification
- Weakness
- CWE-20 Improper Input Validation
References
- access.redhat.com /errata/RHSA-2018:0585 · vendor-advisory, x_refsource_REDHAT, x_transferred
- debian.org /security/2017/dsa-3966 · vendor-advisory, x_refsource_DEBIAN, x_transferred
- access.redhat.com /errata/RHSA-2018:0378 · vendor-advisory, x_refsource_REDHAT, x_transferred
- hackerone.com /reports/243003 · x_refsource_MISC, x_transferred
- securitytracker.com /id/1039249 · vdb-entry, x_refsource_SECTRACK, x_transferred
- access.redhat.com /errata/RHSA-2017:3485 · vendor-advisory, x_refsource_REDHAT, x_transferred
- lists.debian.org /debian-lts-announce/2018/07/msg00012.html · mailing-list, x_refsource_MLIST, x_transferred
- securityfocus.com /bid/100579 · vdb-entry, x_refsource_BID, x_transferred
- access.redhat.com /errata/RHSA-2018:0583 · vendor-advisory, x_refsource_REDHAT, x_transferred
- security.gentoo.org /glsa/201710-01 · vendor-advisory, x_refsource_GENTOO, x_transferred
- blog.rubygems.org /2017/08/27/2.6.13-released.html · x_refsource_MISC, x_transferred
- github.com /rubygems/rubygems/commit/8a38a4fc24c6591e6c8f43d1fadab6efeb4d6251 · x_refsource_MISC, x_transferred
- nvd.nist.gov /vuln/detail/CVE-2017-0900 · advisory
- github.com /rubygems/rubygems · package
- web.archive.org /web/20190212090616/http://www.securitytracker.com/id/1039249 · web
- web.archive.org /web/20200227143907/http://www.securityfocus.com/bid/100579 · web
Sources
- CVE List: CVE-2017-0900
- GitHub Advisory: GHSA-p7f2-rr42-m9xm
- NVD: CVE-2017-0900
vulnwire keeps one entry per vulnerability: the CVE id wins, then GHSA; records that alias each other are merged. Machine-readable: JSON.